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Dobby Design in Photoshop®
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The dobby weaver will want to work with existing weave programs 
to create threadings and to drive the loom. Photoshop adds a new 
capability to dobby designing. We may utilize the special strengths 

of Photoshop to create liftplans which are easily resized and adapted to 
variations in sett without redoing the entire file from scratch. An even more 
exciting use of Photoshop in dobby design is being able to take advantage of 
Photoshop’s filters in the design process itself. We begin by discussing the 
link between Photoshop and existing dobby software.

Importing Photoshop Files into 
Weave Programs

As of this writing, four weave programs permit the importing of graphics 
files: ProWeave (Macintosh and Windows), WeaveMaker (Macintosh and 
Windows), WeavePoint (Windows), and Fiberworks PCW (Windows). 
Graphics for import should be indexed to black and white, and have a 
resolution of 72 dpi. For more information, contact the software vendors. 
Addresses may be found in Appendix J.

ProWeave
ProWeave for Macintosh allows a simple cut and paste. The material 

copied from Photoshop should be at 72 pixels per inch, indexed (black and 
white only). ProWeave should be set up in 1 pixel scale. Paste the image onto 
the ProWeave screen, select it with the marquee, Draft>Make Object, and 
then use the object with a threading and tie-up (straight diagonal line) to do 
a drawdown (Draft>Make Drawdown). 
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ProWeave for Windows does not permit a direct cut and paste from a 
graphics program. The image should be saved in Photoshop (black & white 
only) as a bit-mapped file (.bmp), then opened in ProWeave. Once the image 
is opened in ProWeave, proceed as above for Macintosh version.

WeaveMaker
WeaveMaker, both Macintosh and Windows versions, allows pasting of 

graphics files into the liftplan area of a dobby file. Copy the black and white 
graphic liftplan in Photoshop, then go to Weavemaker and paste. A paste 
icon will appear in place of the cursor. Position the paste icon over the bottom 
right corner of the liftplan and click. 

WeavePoint
WeavePoint (for Windows only; unfortunately there is no Macintosh 

version) allows pasting of graphics files into the liftplan area of a dobby file. 
Copy the black and white graphic in Photoshop, then in WeavePoint first 
select the area in which to paste. It is not necessary to select the entire area 
–one pixel will do; select the lowest lefthand square in the desired paste area, 
and the paste will flood in upwards and to the right.

Fiberworks PCW
Fiberworks PCW provides for graphic import through the Sketchpad. 

Open Fiberworks, Open Sketchpad, choose the .bmp file. It will open in a 
grid. Regrid to 1 grid square to one black square if needed. The grid may have 
to be adjusted left/right or up/down. If it is one square per pixel, then no grid 
adjustment is needed. There are two ways to get the image into the liftplan in 
the Design window. 

Method 1: Go to Analysis and choose Analysis>Make drawdown. Choose 
Pegplan in the popup dialog. The draft will now appear in the design window 
as a liftplan. You may also do this by copy/paste from the Sketchpad.

Method 2: Select one repeat, or the image as appropriate. Go to Edit> 
Copy or use Copy tool or CTRL + C. Open a design with max shafts and 
treadles (64x64) or the appropriate number if you know it. Click into the top 
left of the liftplan and then Edit>Paste or use the paste tool or CTRL + V.

Another Translation Method
If you are using a weave program that does not currently accept graphic 

import, and if you have enough patience, you may enlarge the scale of your 
Photoshop image, turn on a single pixel grid, do a screen capture, print it out, 
and enter the liftplan into your weave program one square at a time: inelegant 
but doable.

Clever weavers will invent other ways of importing graphics into their 
weave programs. We are a hardy bunch.
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Setting up a Template for a  
Two-weave Dobby Design

In Photoshop open a new RGB file whose width in pixels 
equals the number of shafts on the loom, and whose length 
in pixels is a multiple of a single repeat of the weave structure 
being used. For instance, for a 4-end twill, the length would be 
a multiple of 4 pixels; for an 8-end satin the length would be 
a multiple of 8 pixels. Zoom the file to about 600% for easier 
visibility. If you wish, turn on the grid (View>Show>Grid).

Drawing a Design
Using the Brush tool, paint or draw an image on the 

Background layer (click on Background in the Layers palette), 
as in Figure 15-1, then in the Menu, perform Layer>New 
Adjustment Layer>Threshold. In the Threshold window which 
appears, be sure that the Preview button is checked, drag the 
triangular slider right or left to your satisfaction, and click OK. 
In the Layers palette, click on the Background, and continue 
drawing. Notice that now everything you draw in gray or colors 
is immediately reduced to either black or white pixels because 
of the Threshold layer above it (Figure 15-2). 

If you highlight the Background layer and paste a colored image on top of 
it, so that the Threshold layer is still topmost in the stack, the appearance of the 
window will still be reduced to black and white (Figure 15-3). If you double 
click on the layer thumbnail (circled in  Figure 15-4) just to the right of the 
eye icon on the Threshold layer, the 
Threshold dialog will reappear, and 
you may adjust the Threshold level 
again. Doing the thresholding in an 
Adjustment Layer is a good way of 
preserving your options. You may 
always revisit this adjustment and 
change it, as the adjustment is non-
destructive. 

Assigning Weaves
Preparation

Now you may assign weaves. 
Duplicate the file, save the original 
in case you want to revisit it later 
and make changes to the image, and 
from now on work on the duplicate. 

Remove the pasted colored 
layer (which was for demonstration 

15-1 15-2
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purposes only–we don’t need it any more) by dragging the layer onto the 
Trashcan icon at the bottom of the Layers palette. Flatten the file (Layer>Flatten 
Image). With Magic Wand tool selected, Tolerance 0, Anti-alias, Contiguous, 
and Sample All Layers all unchecked, click on a black pixel. All black pixels 
are now selected. Layer>New>Layer via Copy (or Command (Control)-J). 
This will create a new layer containing nothing but the black pixels. Name 
this layer Weave X. Click on the Background layer in the Layers palette to 
highlight it, and this time click on a white pixel with the Magic Wand. All 
white pixels are now selected. Perform Command(Control)-J once again, 
and a new layer containing only white pixels will be created. Name this layer 
Weave Y. 

Weaves as Layer Styles
Weaves are assigned the same way as for jacquard (see Chapter 4). In 

brief, highlight the layer named Weave X, then Layer>Layer Style>Pattern 
Overlay, in Layer Style window uncheck Link with Layer, choose desired 
Pattern, click OK. Repeat the process for Weave Y, choosing desired weave 
pattern (Figure 15-5). If the words “Effects” and “Pattern Overlay” are not 
visible in your Layer Palette, click on the small disclosure triangles to the 
right of the “f” symbol to reveal them (Figure 15-6).

Transporting the Liftplan
Duplicate your file, save the original, and work on 

the duplicate. Select>All, Edit>Copy Merged, and you 
may now paste the liftplan into your weave program.

Figure 15-7 on the next page shows the liftplan after 
pasting into WeaveMaker, with two repeats of straight 
threading and two repeats of the liftplan.

 Possible Threadings
Let’s pause and consider which threadings will be 

appropriate for our Photoshop-designed liftplans.

Straight Threading
Obviously, a straight threading (or straight draw) 

would cause the liftplan to be reproduced in the cloth, 
the size of the horizontal repeat being determined by the 
number of shafts employed. In other words, a liftplan 
16 pixels wide and 48 pixels high applied to a straight 
threading on 16 shafts with a sett of 16 epi would repeat 
width wise every inch. If this cloth were to be woven 
square, the ppi would also be 16, and the design would 

15-5
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repeat lengthwise every three inches (48÷16). Some 
weavers have labeled this use of a straight threading 
on a dobby loom a “mini-jacquard,” and indeed it 
is–we are using the method of single thread control 
on a virtual loom of 16 heddles.

Advancing and Networked Threadings
Our designing scope is greatly increased if we 

consider threadings that conform to a network. 
(Many, but not all, advancing threadings are 
included in this group.) For more information on 
network drafting, refer to Schlein, Network Drafting: 
an Introduction in the Bibliography. The following 
few paragraphs, however, will get you started.

A threading network is built from the repetition 
of an initial. An initial is the minimum amount 
of information necessary to define a threading. A 
four-end initial defines a straight threading on four 
shafts, on which may be woven plain weave, straight 
and broken 4-end twills (3/1, 2/2, 1/3), basket 
weave, double weave, and many other weaves. Any 
weave which may be woven on the 4-end straight 
threading may also be woven on any draft plotted on 
a network derived from the corresponding initial. 
Additionally, two or more of these weaves may be 
combined in a single liftplan and woven successfully 
on these networked threadings.

Likewise, any threading draft plotted on a 
network derived from a 5-end straight initial may be 
woven with liftplans composed of any 5-end satin. 
Networks derived from 8-end straight initials may 
be used as the basis for threadings on which 8-end 
satins, plain weave, double weaves, 4-end twills, and 
so on, may be woven.

15-7
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Following are examples of 4-end and 5-end initials and networks:

15-8     16 shafts, 4-end initial

15-9     15 shafts, 5-end initial

Following is an example of a threading plotted on a network derived from 
a straight 4-end initial:

15-10
Following is an example of an advancing twill which happens to fall on 

the same network:

15-11

And on the next page we see what our Photoshop liftplan looks like on 
that advancing twill threading, in WeaveMaker (Figure 15-12).

Notice that as a single threading repeat of this advancing twill is five 
times as long as a single repeat of straight threading, the motifs are expanded 
fivefold width wise. Even though the edges of the design have become ragged 
through the effects of network drafting, the integrity of the weave structures 
remains intact, because the underlying network has been followed. If we wish 
to extend the design lengthwise to compensate, it is necessary to go back to 
the original Photoshop design file. Here is how we would do this.



301Dobby Design in Photoshop

Expanding Length of Liftplan
Returning to the layered Photoshop file, Figure 15-5 (5aWeaves.psd), and 

looking at the Layers palette (see Figure 15-6), we see that the X and Y layers 
have weaves applied as Layer Styles. This will enable us to resize the file and 
still retain the weave assignments. Duplicate the file and work on the duplicate 
(5bWeaves.psd). Let’s elongate this file by doubling its length (we could triple 
or quadruple it, or indeed elongate it by any factor, as long as the length is still 
a multiple of 4 pixels, 4 being the size of our initial). Image>Image Size, and 
in the Image Size window uncheck Constrain Proportions, Check Resample 
Image (Nearest Neighbor), and look in the Height box. Current value is 96 
pixels, and we will double this number and enter 192. Click OK. Save. Notice 
that the image is now elongated, but the weaves are still correct. The new 
Photoshop file looks like Figure 15-13 on the next page.

Duplicate this file, flatten it (Layer>Flatten Image), Select>All, 
Edit>Copy, and go to the WeaveMaker file. While in WeaveMaker, 
Edit>Paste, position the loaded cursor over the lowest right hand corner of 
the liftplan, and click. The elongated weave image will flood into the liftplan 
area.  If using another weave program, use the appropriate paste routine for 
that application. The new draft looks like Figure 15-14.

Finally, take a look at this new liftplan with a networked threading based 
on a curve (Figure 15-15 on the next page).

15-12
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15-13

15-14

15-15
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Photoshop Design Tools for Dobby
The Offset Filter

Now that we know how to get Photoshop files with their applied weaves 
into weave programs so that we may drive our looms, let’s explore some of the 
versatile design tools that Photoshop affords us. This is, after all, why we are 
going to the trouble of using Photoshop for our dobby design.

For this example let’s revisit our hypothetical 24-shaft loom. (The process 
would be the same for other looms, such as 16-shaft, 32-shaft, and 40-shaft. 
The pixel width of the file would change to 16, 32, or 40 in these cases.) We 
will use a straight threading, and our liftplan will be a multiple of 4. Open a 
new Photoshop file in RGB mode, with a size of 24 pixels wide by 96 pixels 
high, resolution 72 pixels per inch, Background white. Zoom in to at least 
400% for easier viewing on screen. Choose the Brush tool, diameter around 
8 pixels, default foreground color (black), mode normal, opacity and flow 
100%. So far there is only one layer (the Background layer); using the mouse 
or graphics tablet and pen, draw on this layer. You may use the Eraser tool 
to make corrections, but we find it easier to stay with the Brush tool and 
simply switch the foreground and background colors (black and white) with 
the keyboard shortcut “X”. With one hand on the mouse and the other on the 
“X” key, this process goes very quickly. 

Notice that the edges of the design are anti-aliased with gray pixels to 
produce the illusion of smoothness. We want to eliminate everything but 
black and white pixels, but we will do this later. The question arises: why not 
draw in Bitmap or Index Mode with a black brush on a white background, to 
automatically force only black and white pixels? The answer is that in these 
modes we lose the ability to use layers and filters, so we will work in RGB 
mode for now (Figure 15-16).

As there are no parts of the 
design that touch the side edges, 
we may assume that the design 
will not conflict with its neighbors 
in the horizontal direction, but 
we want to see how the top and 
bottom edges connect when the 
design is repeated in the liftplan. 
Filter>Other>Offset will give us 
this information. Perform this 
command, and in the resulting 
Offset window, with the Preview 
and Wrap Around buttons 
checked, slide the Vertical slider 
back and forth to see the effects 
of wrapping; alternatively, you 
may enter a value directly into 
the Vertical pixels down box. A 15-16 15-17 15-18
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value of around 48 will put the repeat area right in the 
middle where it is easily seen. (You can also try minus 
numbers here.) Click OK. The image is now wrapped 
halfway down. In this view correct the join area with 
the brush and black and white paint. The wrapped 
image before and after correction is seen in Figures 
15-17 and 15-18 on the previous page.

To add elements to the design that will connect 
it sideways, do another wrap, but this time in the 
horizontal direction. Filter>Other>Offset, Horizontal 
12, Vertical 0. The design is now wrapped halfway 
to the right, and with the Brush tool add an element 
or two to connect the designs. The wrapped version 
before and after this addition is shown in Figures 15-
19 and 15-20.

The Threshold Adjustment
It is now time to reduce the design to black and white. Layers>New 

Adjustment Layer>Threshold will bring up the New Layer window; click 
OK. Now the Threshold window appears; with the Preview button checked, 
move the slider triangle under the histogram back and forth to preview the 
results of the operation in your design. When it is to your satisfaction, click 
OK. We chose a value of 170 to make the design moderately bold. Moving 

15-19 15-20

15-21
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the slider to the left will make the black areas narrower. 
The Image Window, Layers palette, and Threshold control 
window for this operation are seen in Figure 15-21.

It is possible to revisit the Threshold control for 
further adjustment at any time, as long as the file is saved 
as a Photoshop file (.psd) with layers intact. In the Layers 
palette, highlight the Threshold layer, and double click on 
the gray Layer Thumbnail immediately to the right of the 
eye icon for that layer. The Threshold window will reappear, 
and the slider may be adjusted again. This is another 
example of the advantage of working with Adjustment 
Layers; all the operations are infinitely adjustable, even 
after the file is saved, closed, and reopened!

If you prefer to leave the Threshold layer in place, you 
may make changes to the drawing by highlighting the 
Background layer to make it the active layer, draw, erase, 
and apply filters to the Background, and the thresholding 
will update as you work. If you wish to leave the Threshold 
layer in place but turn off its visibility temporarily, merely 
click on the eye icon for that layer to render it invisible. 
You may turn it back on at any time. 

In addition to the Offset filter and the Threshold 
image adjustment, there are a number of other tools we 
find useful in dobby work.

The Shear Filter
In a new RGB file of 40x96 pixels, with the Brush tool, we have drawn a 

rough vertical stripe down the center of the image, and checked the meeting 
of the top and bottom borders via the Offset filter, as described in the previous 
example. Distort this stripe to make gentle waves. Filter>Distort>Shear, 
for Undefined Areas choose Wrap 
Around, and click and drag on the 
vertical line in the Shear window. You 
will see the effects of the shear in the 
small proxy image at the bottom of the 
Shear window (Figure 15-22). When 
the image is the way you want it, click 
OK. 

The resulting image, both before 
and after the Threshold adjustment is 
shown at Figures 15-23 and 15-24, and 
the file with weaves applied at 15-25.

15-2515-2415-23

15-22
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Finally, here is the file in WeaveMaker with 
a straight draw (Figure 15-26), and also in an 
elongated version with an advancing twill (when 
resizing the file, be sure to use “nearest neighbor” 
as the resampling method and remember to 
resize to a number evenly divisible by the initial) 
(Figure 15-27).

The Stamp Filter
This filter smooths and distorts the image in 

fluid and unpredictable ways. When applying 
it, use the slider controls to adjust the settings 
to your liking. The filter works differently on 
smaller images, and it will take some fiddling 
with the sliders to get usable results.

On the next page is an example of a liftplan 
for a 16-shaft dobby loom, which may be used for 

15-26

15-27
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straight draw or an advancing threading that conforms to a network. Start 
with a 16x160 pixel RGB file, and draw on it with the Brush tool, wrapping 
several times with the Offset filter to check on joins at the edges. After the 
drawing is complete, apply the Stamp filter (Filter>Sketch>Stamp, and be 
sure the foreground and background colors are set to the default black and 
white). Then apply the Threshold adjustment. Touch up the boundaries by using 
the Offset filter and the Pencil tool with black or white. Finally, assign separate 
layers for the black and white pixels and apply weaves as Layer styles.

In Figure 15-28 the steps shown, from left to right, are: original drawing, 
Stamp filter applied, Threshold applied, weaves applied, and final drawdown 
in WeaveMaker.

15-28
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The Ripple Filter
Figure 15-29 shows the original 24 by 96 pixel image for 

a 24-shaft loom, and the Ripple controls. In Figure 15-30 the 
Rippled image was touched up via the Offset filter, has had 
Threshold applied and the weaves added. The resulting liftplan 
is used with straight draw in WeaveMaker, and shown in 
Figure 15-31.

The previous examples of the use of Photoshop filters and 
adjustments to design dobby designs only scratch the surface 
of possibilities for weavers. Spend a few hours experimenting 
with your own designs and other filters, such as Sponge, 
Crystallize, and Photocopy, and you will quickly become a 
Photoshop for Dobby fan.

15-29

15-30 15-31
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Using Dobby or Shaft Loom  
To Test Weave and Sett

If the size of your jacquard weave structure repeat is compatible with the 
number of shafts on your dobby loom, it is a simple matter to put short warps 
on the dobby loom to test yarns and setts. For instance, if you are testing 8-end 
satins and weaves compatible with them, such as plain weave, double weaves, 
twills, and others, and you are working with an 8-, 16-, 24-, 32-, or 40-shaft 
dobby loom, warp your loom with a straight draw and enter multiples of your 
proposed weave structures in the liftplan. 

Figure 15-32 shows an example of a weave based on an 8-
end multiple; 15-33 is the weave used as a liftplan on a straight 
threading on an 8-shaft loom; and 15-34 is the same weave used 
as a liftplan on a 24-shaft loom.

It is much more efficient to warp a dobby loom with a small 
sample warp to test yarns and weaves than it is to set up a 
jacquard loom for this purpose. One caveat: if testing for ppi for 
a jacquard, a narrow dobby or shaft loom sample might have a 
different ppi than the final ppi in a wider web on the jacquard 
which uses different weaves combined per shot.

Conversely, it can be useful to test new dobby weaves (for 
other than straight threadings) on a jacquard loom if the jacquard 
loom is already set up and available. You will be 
limited to the yarn & sett on the jacquard loom, but 
if you merely want to explore structure, it is quicker 
than rewarping a dobby loom with a new threading.

Here is an example. We have designed a fancy 
networked twill and would like to see it woven without 
going to the trouble of warping the dobby loom with 
this complex threading. Our jacquard loom is ready 
and waiting. We copy the cloth area of the drawdown 
from our weave program into Photoshop. We extend 
this to exactly the number of threads on our jacquard 
setup, in our case, 880 for the TC-1. If necessary, 
repeat the design to fit the total number of ends on 
the jacquard loom. We save the new Photoshop file as 
a .bmp or .tif, import it into the jacquard loom driver, 
and weave it. We may tweak the weave (changing 
threadings or liftplans or both) in the dobby weaving 
software and repeat the process of bringing it to the 
jacquard to weave samples as many times as necessary until the weave is 
to our satisfaction, and only then warp the dobby loom. What a timesaver! 
Examples are on the next page.

15-32

15-33

15-34
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Figure 15-35 is a weave designed in WeaveMaker. Figure 15-36 is the 
same weave exported from WeaveMaker as a .tif, which can be copied into a 
Photoshop file and replicated as many times as necessary to make up the width 
of the jacquard warp (Figure 15-37), and then woven on the jacquard loom.

15-35
15-36

15-37


