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In Chapter 5 we looked at projects with two weave structures; design files 
were reduced to two colors, black and white, and the weaves assigned 
to these two areas. When more than two weaves will be used in a 

Photoshop file, we should look into color indexing as a way of managing the 
information. 

An RGB file may contain many thousands of colors; in order to group the 
pixels into manageable units for assignment of weaves, we must reduce the 
number of colors in the file. Even if we are using only black and white yarns, 
by judicious choices of weave structures we may develop a palette of many 
shades of gray, and we find it convenient to order the colors in our file to 
correspond to the number of weaves we will be using.

Working Backward from a Known 
Set of Weaves and Color Table

A first step would be to weave a color blanket with the yarn and sett 
exactly corresponding to those in the project, containing all the weaves we 
have chosen as suitable for the project. For instance, we might want to weave 
an image in the seven shades 
of gray possible in the shaded 
8-end satin family. Figure 6-1 
shows a typical image file for 
a blanket comprising seven 
shades of gray.
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The same blanket with shaded satins (1/7 through 7/1) assigned is shown 
in Figure 6-2.

Other blankets might be woven for other sets of weaves; for instance, 
a group of compound satins with a single warp and several wefts might 
produce 20 or 30 different weaves and an extensive color palette with many 
hues and tones, and several different textures, not just a range of tonal values. 
Weaving a blanket of such weaves in a given yarn and sett is important in 
order to establish what the available palette really looks like and to determine 
a ballpark figure of the ppi. 

We would typically analyze the blanket and from it choose a subset of 
weaves for our project; for instance, we might choose a dark red square, a 
light red, medium green, pale green, medium blue, light blue, dark gray, light 
gray, and black, a total of nine weaves. We could then build a palette of these 
colors in Photoshop and save it as a Color Table. Here is one way to do this.

Create a Color Table
Create a small temporary RGB file. Index it by going to 

Image>Mode>Indexed Color, then choose Palette: Local (Adaptive), 
Colors: 0, Forced: None, Transparency unchecked, Dither: None. Click OK. 

If we go to Image>Mode>Color Table, we will see a table 
with no colors; all the squares are blank (gray). What we’ve 
done is create a small temporary color table which will be the 
starting point for the creation of a custom table. Color Tables 
are not available in RGB Mode; that is why we had to go to 
Indexed Color Mode.

Now with the Color Table window still open, click on the 
first square, and the Color Picker window will open. Using 
the various sliders and buttons, choose the first color, which 
will be a dark red, since we are imitating the colors in the 
weave blanket. (For more information on how to use the 
Color Picker, refer to the Help menu or to your Photoshop 
manual. The Color Picker in Mac and Windows is slightly 

different.) Still in the Color Table window, click on each square in turn, fill 
with a color, until all nine colors have been created. Then click on Save and 
give it a descriptive name; Photoshop will automatically assign the .act suffix, 
which indicates that it is a Color Table. It can be saved in any location. A good 
place to keep it would be in the Workfiles folder for a given project. At this 
point our Color Table looks like Figure 6-3.

6-2
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Note: Images 
can be found 
in color in 
the Chapter 6 
folder of the 
CD.
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We may also load the Color Table (.act) files into the Swatches 
palette, and use the same set of colors there. If the Swatches palette 
is not visible on screen, go to Window>Swatches. In the Swatches 
palette we have choices of view mode; access these choices through 
the little flyout triangle at the upper right of the palette. The choices 
are Small Thumbnail, Large Thumbnail, Small List, and Large List. 
Figures 6-4 and 6-5 show Large Thumbnail and Large List options. 

We may also give the swatches more descriptive names by double 
clicking on each item in the list and renaming it, as in Figure 6-6.

We may in turn save this renamed palette from the Swatches 
window, via the flyout triangle (Save Swatches). Palettes saved from 
the Swatches palette are automatically given the suffix of .aco. Note 
that palettes with the .act suffix are interchangeable with palettes with 
the .aco suffix; that is, either type of palette may be opened from either 
the Color Table window or the Swatches palette. Indexed files will only 
permit the use of colors in the file’s associated Color Table. If you 
select a swatch from an RGB Swatch palette for an indexed image, the 
Swatch color will be modified to the closest index color in that file’s 
Color Table. We will discuss more about Color Tables and Swatches 
later in this chapter.

Working Forward from an Image  
To a Color Table

Instead of working toward a known set of weaves and color palette, 
it might be that a particular image or design is the starting point for 
a project, and the palette is yet to be determined. Here is an example 
of how we might proceed. We will start with the image FrangiCenter.
psd. The upper left corner of the image is shown in Figure 6-7 on the 
next page.

From this starting point we  go to Image>Mode>Indexed Color, 
and in the Indexed Color Dialog Box, with Preview checked, we try out 
various options. There are several choices here, and you should explore 
them, but usually we use Local (Adaptive) for the Palette, and Forced: 
None (we are not using a predetermined Color Table this time). We like 
the look of this image when 10 is chosen as the number of colors. If we 
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want large flat areas of color with a posterized effect, we choose Dither: None. 
If we want an extreme pixellated style of color blending with the 10-color 
palette, we choose Dither: Diffusion. When choosing dithering, we have 
the option of various amounts; try various settings, all the way from 0 (no 
dithering) to 100%, or maximum dithering. We may also experiment with 
the other dither settings of Pattern or Noise, although note that no percentage 
amounts are available with these options.

The original image, FrangiCenter.psd, is shown at Figure 6-7. For indexing 
and no dithering, see Figure 6-8. For indexing and 50% dithering, see  Figure 
6-9. For indexing and 100% dithering, see Figure 6-10. After the image is 
indexed, you can go to Image>Mode>Color Table and see the 10 colors. You 
can also save them as an .act for future use.

Reordering Colors in the Palette
Sometimes it makes more sense to reorder the colors in a palette so that 

they conform to light/dark order, or ranking of hues, or some other scheme. 
It is possible to do this in Photoshop, although not as easy as one would like. 
Here is the way we do it.

6-7   The original image 6-8  Indexed to 10 colors, no dithering

6-9   Indexed to 10 colors, 50% dithering 6-10   Indexed to 10 colors, 100% dithering
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Figure 6-11 shows a Color Table 
generated by indexing an RGB file to 
7 colors. We would like to reorder the 
colors to this sequence: light gray, pink, 
red, lime green, medium green, dark 
green, black. First we save the table 
as 7colors.act. Then we open it in the 
Swatches palette (Figure 6-12). The 
Swatches Palette may be changed to the  
list view via the flyout triangle on the 
upper right corner of the palette. We then decide which color will be the first 
in the list (the pale gray D5DAE8 in this case), drag it on top of the Create 
New Swatch icon at the bottom of the palette (the little turned-up page), 
which makes a copy of it, and give it a distinctive name Lt. gray). Notice that 
the original swatch is not eliminated–we have only created a duplicate. Do 
this with each swatch in turn in the order desired. The finished list now looks 
like (Figure 6-13).

When we are sure all the original colors are duplicated, the final step is 
to delete the originals. Drag each original to the Trashcan icon at the bottom 
of the palette, or hold down the Option key and click on the swatch. You will 
see a scissors icon appear over the swatch, and then the swatch will disappear 
when you click on it. The Swatches palette now looks like Figure 6-14.

6-11
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Save the palette as 7colorsReordered.
aco. It may now be loaded into either the 
Color Table window or the Swatches 
palette. Figure 6-15 illustrates our reorder 
palette loaded into the Color Table.

Note: if we load the reordered palette 
into the indexed file, the colors in the 
image will be reordered, too. Indexed 
colors are identified by their position 
in the table. If we change the color’s 

position (index number), then any motif filled with the index color of the 
original index position will take on the color that has been moved to that 
position. This is not what we want.

Instead, we go back to the original RGB file before indexing and 
Image>Mode>Indexed Color, Palette: Local (Adaptive), Colors: 7, Forced: 
Custom, Dither: None; we are then taken to the Forced Colors dialog box, 
where we click on Load, then navigate to 7colorsReordered.aco, click OK. 
Our image is now indexed as it was the first time, but with the colors ordered 
the way we want them. Check the reordered Color Table (Figure 6-15) and 
compare it with the one in Figure 6-11.

Forced Colors tells Photoshop to use the colors of whatever palette we 
designate, and gives us back control of the color order in our palette.

Why Bother to Reorder 
Colors?

Why would we go to so much 
trouble to order the colors? Here is 
where a reordered palette is useful: at 
the very bottom of our indexed file we 
add a small border (by Image>Canvas 
Size), and within this border paint 
a small chip of each color in the file. 
We choose our colors in order from 
the Swatches palette, into which we 
have already loaded our reordered 
Color Table. We then convert the file 
to RGB. With the Magic Wand tool, 
(Tolerance 0, Anti-alias, Contiguous, 
and Sample All Layers all unchecked), 
Background layer highlighted, click 
on each chip in turn to identify all 
pixels in the image with that color, 
and to make separate layers for adding 
weaves. 

6-15
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6-18

Ordering colors in this way can help your decisions about the sequence 
of weaves to be used; ordering helps you remember which color will become 
which weave. The  file with color chips is shown in Figure 6-16 at the bottom 
of the previous page.

Reducing Number of Colors in a Color Table
It is also possible to reduce the number of colors in a Color Table by 

combining two or more colors. This process is easier if the colors are first 
reordered as described in the previous section.

In Figures 6-17 and 6-18 we see an indexed image and its associated Color 
Table containing 30 colors. We would like to reduce it to 27 colors. There is 
instant feedback in the image, so we may observe changes as we make them, 
and undo unwanted changes on the spot.

6-17
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The Color Table is saved as Frangi30.aco, and 
is loaded into the Swatches palette. It looks like 
Figure 6-19.

After reordering, so that families of color sit 
together, the Swatches palette looks like Figure 6-
20. Save this palette as Frangi30Reordered.aco, 
reopen the original FrangiColorful.psd (before 
Indexing), then perform Image>Indexed Color, 
and choose Custom palette; navigate to the 
reordered palette, load it, click OK.

Choose Image>Mode>Color Table, and now 
with the Color Table window open, examine the 
colors and determine adjacent groups which may 
be combined (Figure 6-21). Drag the mouse pointer 
over a group, and in the resulting window, choose 
the color you would like to assign to all colors in 
the group (jot down the hexadecimal value of this 
color for reference), click OK.

In the next window, choose the same color by 
assigning the same hexadecimal value and click 
OK. Now all colors in the group are assigned the 
exact same identity. Repeat this process for any 
other groups of adjacent colors you would like to 

combine. You may combine any two 
or more adjacent colors. To achieve the 
actual reduction, convert the indexed 
file back to RGB, then index it again; 
be sure that this time Forced: None is 
chosen as an option. Note that the size of 
the Color Table is reduced by combining 
all duplicates (Figure 6-22). The colors 
may have to be reordered again as a final 
step. We reduced our Color Table by only 
three colors, but of course we could have 
reduced it much more.

6-19 6-20

6-21
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Painting with a Restricted Palette
When we design directly in Photoshop with brushes (virtual painting), 

and wish to restrict our palette to a fixed number of colors, we start out with 
a new RGB file (File>New), then go to Image>Mode>Indexed Color, and 
in the Indexed Color dialog box choose Forced: None, Palette: Custom, then 
in the Color Table dialog choose Load, and load your desired palette. Click 
OK. Open the Swatches palette, load the same color palette, and click OK. 
Now we may paint with the Brush tool, choosing colors at will by clicking 
on the swatches in the Swatch palette, and our painting will contain only 
those colors in our chosen palette. There will be no anti-aliasing at the edges 
because we are in Index Mode. Text may be added as well with the chosen 
palette, but it will not be on a separate layer (Indexed Color mode does not 
permit layers).

The advantage of designing in Indexed mode is that we know immediately 
which pixels are assigned to a particular color and no further indexing or 
color management needs to be done. The disadvantage is that no layers are 
available in this mode, so design elements cannot be shifted, reordered, or 
further reworked. The file may be resized, but there will be a coarse blockiness 
if it is sized up, and unpredictable results if sized down. Weaves can be added 
as Fills in Indexed mode, but only 
if the structure has been saved as a 
Pattern while in Index mode and 
the Color Table of the indexed image 
file has the same black and white in 
it. This is tricky, so we recommend 
that you do the following. After 
designing in Indexed mode convert 
back to RGB, separate the colors into 
individual layers, then assign the 
weaves as Layer Styles. In that way, 
resizing may be done if necessary, to 
conform to changes in sett and Pixel 
Aspect Ratio, without having to redo 
the weave assignments.

We drew the following small 
sketch in Indexed Color mode, using 
a Color Table of six colors: yellow, 
red, green, blue, black and white (see 
Figure 6-23).  Note that the colors are 
distinct and blocky. If we had done 
a similar drawing in RGB mode, 
using six colors, it might have looked 
like (Figure 6-24), and after indexing to six colors it would look like (Figure 
6-25), with the colors distributed in unpredictable places. Compare these two 
methods of drawing directly in Photoshop, and choose the one which suits 
your personal style.

6-23
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