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A Two-Color Damask Design

Project 1: A Two-Color Design

In this chapter we will go through the steps in designing three projects 
for one warp and one weft, with two weaves: one a 4/1 satin (warp 
effect) and one a 1/4 satin (weft effect, or sateen). This construction is 

also known as damask and has been used for centuries. Damasks are often 
monochromatic. Our examples are woven with a white warp and black 
weft for clarity, but a single color could have been used as well, the contrast 
of the two satin textures providing the sole visual effect. 

We will work with a black and white image. We could have chosen 
any two colors for this step, because at this point in the process the colors 
represent placeholders for later input of weaves, and not actual weaves.

We are designing for the face of the cloth, with a simple cloth structure, 
in which all ends and picks lie in the same plane. Consequently, the face 
design and the final structural image will have the same pixel dimensions. 
One pixel in the design will represent the intersection of one warp and 
one weft. We envision that the cloth will weave square, that is, the ppi will 
be the same as the epi, giving us an aspect ratio of 1. If after weaving a 
small sample we find that the ppi is not exactly the same as the epi, we will 
calculate a new Pixel Aspect Ratio and resize the file before weaving the 
final cloth. Our loom is a TC-1 set up with 880 ends at 30 epi.

Photoshop presents us with a wealth of tools for producing an image in 
two colors. Start with any digital image file (photograph, scan, computer 
drawing). In this example we have used a photo from a digital camera, and 
will detail the steps in reworking the image to produce a black and white 
file which will be suitable for the addition of weaves.

Note: The 
working files 
referred to in 
this chapter may 
be found on the 
accompanying 
CD. You will find 
it helpful to view 
these files and 
their associated 
palettes as you 
read the process 
descriptions. 
There are also 
photos of the 
three woven 
fabrics described 
in this chapter; 
all can be found 
in the Chapter 5 
folder.
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First Image: A Photo with Minimal Styling
Preparing the Image

The starting image is Frangipani2472.psd, an RGB image that has the 
pixel dimension of 1440 wide and 1200 high, resolution 72 pixels/inch. Resize 
it by Image>Image Size, and in the Image Size dialog box check Constrain 

Proportions and Resample Image: Bicubic, enter 
resolution 30 pixels/inch (we already know that our 
loom is set up this way), and for Pixel Dimensions, enter 
width 880. The height will automatically become 733 
pixels. (We could also change the height to a number 
evenly divisible by 5, the height of our structures, but 
it is not necessary in this example, as the file is non-
repeating.) Click OK and then File>Save As, and give it 
a new name (Frangi1.psd in this case). We will improve 
the contrast by Image>Adjustments>Shadow/
Highlight. We like the effect with the default settings, 
but you may adjust the sliders in the dialog box to your 
liking, then click OK. Save your work. The image looks 
like Figure 5-1.

Styling the Image
We will perform the following adjustments as Adjustment layers so that 

we may change them later if desired. 
•Select>All
•Layer>New>Layer via Copy
•With the new layer highlighted in the Layers palette, and the colors set 

to the default black and white in the Tools palette (Keyboard Shortcut: D), 
Filter>Sketch>Photocopy. In the dialog box, adjust the sliders to your liking. 
We used the settings Detail: 22, Darkness: 21. Click OK. 

 •Layer>New Adjustment Layer>Threshold. Adjust the sliders. We chose 
Threshold level 222. Click OK. Save. This converts the appearance of the 
image to only two types of pixels: black and white. It is still an RGB image 
underneath.

Experiment. Turn layers on and off by clicking on the eye icon to the left 
of any layer. Tweak the adjustments by double-clicking on a layer thumbnail 
(the small images in the Layers palette), and redoing the slider settings.  Layers 
may be adjusted regardless of their order in the palette, and the changes will 
appear in the image. If it is necessary to resize an image after weaving a 
sample, the Layer Styles will still be valid. At the very bottom of the stack, the 
base image is still there, ready and waiting for later variations! Save the file as 
Frangi1styled.psd. It now looks like 5-2. Its associated Layer palette can be 
seen in Figure 5-2a.

Duplicate the file. Put the original away. Flatten the duplicate 
(Layer>Flatten Image, or choose Flatten Image by clicking on the flyout 
triangle in the upper right corner of the Layers palette). 

5-1
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Test the file to be sure it contains only two colors. 
Convert it to Indexed Mode (Image>Mode>Indexed, 
Palette Exact, Forced None, Transparency unchecked, 
Preview checked). The number of colors should 
be 2, which is what we want! Click OK. Save as 
Frangi1.indexed.psd. Duplicate the file, and put the 
original away. This might seem like overkill, but we 
like to keep each new version of a file in case we need 
to revisit it. If you find it is redundant for you, ignore 
this step.

Assigning Weaves
Save the duplicate as Frangi1WeavesLayered.psd. 

Convert it to RGB mode (Image>Mode>RGB Color). 
We want to put the black and white pixels on their own layers. Be sure the 
Layers palette is open. With the Magic Wand tool, Tolerance 0, and Anti-
alias, Contiguous, and Use All Layers all unchecked, click on a black area of 
the image. With all the black pixels selected, Layer>New>Layer via Copy, 
or keyboard shortcut Command(Control)-J, and a new layer appears in the 
Layers palette with the default name of Layer 1. You may rename this layer by 
double-clicking on its name–do this now, and call it Black Pixels.

In the Layers palette, click on the Background layer to make it active. With 
the Magic Wand, click on a white area of the image, and with all the white 
pixels selected, Layer>New>Layer via Copy, or use the keyboard shortcut, 
and a new layer appears in the Layers Palette with the default name of Layer 
2. Rename it White Pixels. Save.

We will apply weaves to this file in the next step. You may test this layering 
operation by turning off the Background layer (click on the eye icon on the 
left). The image should appear the same. Now clicking the black layer and the 
white layer off and on, the transparent background (gray checkerboard) will 
show through. Turn all layers back on and save the file.

Here is where we add weaves to the file. Remember that we chose 1/4 
and 4/1 satin as our structures in this project? Any two weaves that work 
together would have served as well, given appropriate yarn and sett. Have 
you saved these weaves to the Pattern Preset folder yet? If not, do so now. 
You can find these Presets on the CD accompanying this book, in the 
subfolder Satins in the Weave Presets folder. They are named 1/4 satin 
and 4/1 satin and look like Figure 5-3a (They are also in the Chapter 5 
folder).

Note: we have set up our weaves in the pattern presets as black=warp up. 
But since our warp in this case is white and our weft black, the weaves will 
appear inverted. We will address this in a minute.

First, the weaves. Go to Edit>Preset Manager, Choose Patterns from the 
drop down menu, and with the Preset Manager dialog box still open, click and 
hold the flyout triangle, and select 5-end satins from the list which appears. (If  

5-2

5-2a

5-3a
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5-end satins does not appear, reread the section on Saving Weaves as Pattern 
Presets in Chapter 4.) Click Done.

In the Layers Palette highlight the layer Black Pixels and click on the “f” 
icon at the bottom to add a Layer Style. In the Layer Styles drop down menu 

choose Pattern Overlay... The Layer Styles dialog will 
open. Click on the triangle at the right of the Pattern 
thumbnail, choose Satin 1/4 from the pattern list, 
Blend Mode: Normal, Opacity 100%, Scale 100%, Link 
with Layer unchecked, and Snap to Origin not clicked, 
Preview button checked, and click OK. 

In the Layers Palette highlight the layer White 
Pixels and click on the “f.” In the Layer Styles drop 
down menu choose Pattern Overlay... Click on the 
triangle at the right of the Pattern thumbnail, choose 
Satin 4/1 from the pattern list, settings as above, and 
click OK. Save.

We like to check for “pixel leaks” at this point. 
Highlight the Background layer in the Layers palette, 
Layer>New>Layer, name it Temp, and fill it with a 
distinctive color (double-click on turquoise in the 

Swatches Palette, then Edit>Fill>Use: Foreground Color, OK). If you turn 
off the Black Pixels or White Pixels layer by clicking the eye icon for that layer, 
you will see the temporary turquoise layer underneath, but when all layers are 
turned back on, no turquoise should be visible. This tells us that all the image 

pixels are filled with Pattern. You may delete the temporary layer at 
this point, but it does no harm to leave it in place. Save. Figure 5-3 
shows a section of the file with the weaves assigned, and Figure 5-4 
shows the associated Layers palette.

Duplicate the file and close the original. Work on the duplicate. 
Notice that the structural weave image appears to be a reverse 
of the dark/light values in the original black and white design. 
This is because the weaves are recorded in the Presets as black = 
warp up, a common drafting convention. But our loom is set up 
with a white warp and black weft, giving us the reverse effect. To 
visualize the woven design temporarily with the correct values, we 
may add another layer: with the top layer highlighted, Layer>New 
Adjustment Layer>Invert. Now it looks the way we expect! Turn 
this layer off or delete it. Flatten the file (Layer>Flatten Image), 
discarding the hidden layers if any.

Preparing a Loom-Ready File
Almost done! Reduce the file to a two color weave plan by Image>Mode> 

Indexed Color, and in the dialog box select Palette: Exact, Forced: None, 
Transparency unchecked. The number of colors should be displayed as 2, 
which is what we want. Click OK. If we go to Image>Mode>Color Table, we 

5-3
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will see the two colors in our table, which are black and white. Click OK. Save 
as Frangi1.bmp, and select 4-bit or 8-bit in the BMP Options window. The 
TC-1 and the AVL Jacquard will read files in .bmp or .tif format. Whenever 
we see a file with the .bmp or .tif suffix, we know this file is ready to weave.

Second Image:
Drawing and Weaving Face Down

Preparing the Image
We will use the same source image as in the previous example, and give it 

a new name (Frangi2.psd in this case). 

Styling the Image
We’d like to do a drawing this time, based on the photograph. We add a 

“tracing paper” layer by Layer>New>Layer, then Edit>Fill, and in the dialog 
box, choose Contents Use: White, Mode:Normal, Opacity 50%. The opacity 
of the layer may be fine tuned with the Opacity slider in the Layers palette. 
Choose the Brush tool, with a size of approximately nine pixels (choose brush 
size in the Options Bar), and for the foreground color choose black (keyboard 
shortcut D for default color). With your mouse or the pen of your graphics 
tablet, draw on the tracing paper, using the underlying image as a guide. Be 
as free as you wish–this is your drawing. From time to 
time dial the opacity slider all the way up to 100% to 
envision the drawing in black and white without the 
base image. When the result is to your liking, be sure 
the opacity is set to 100%, and save as Frangi2styled.
psd. The “tracing paper” layer and the opacity slider 
can be seen in Figure 5-4a.

At this point the drawing is in black and white, with 
many shades of gray softening the edges of the drawing 
lines. We have to simplify this drawing to contain only 
black and white pixels. Do this by adding an Adjustment 
Layer. With the tracing paper layer highlighted, go to 
Layer>New Adjustment Layer>Threshold, click OK. 
In the Threshold dialog box,  move the little triangular 
slider back and forth to see the effects of the various 
threshold settings (be sure Preview is checked). Move 
it to the left to see thinner lines in your drawing, and to the right for thicker 
lines. When the effect is to your liking (we chose a level of 101), click OK. Save 
(Figure 5-4b on the next page). 

5-4a
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Modify for Heavy Lifts
In thinking of the weaves we will be using, namely 

1/4 and 4/1 satin, we want the drawing to appear as 
black lines on a white background. The major portion 
of the image is background in this design. Our warp 
is white, the weft black. If we weave the file this way, 
almost 80% of the warp ends will be rising on each 
pick. The loom will work better if fewer ends are rising 
on any given pick, so we have decided to weave the file 
upside down. So far so good. However, if we do that 
and then flip the weaving to the “wrong” side, the 
image will be reversed from left to right. To avoid this 
situation, we will flip the image left to right before we 
invert it. Highlight the top layer in the Layers palette, 

Select>All, Edit>Copy Merged (this will copy content on all layers, not just 
the active layer), Edit>Paste. Now a copy of the previous content is pasted, all 
together, in a new layer, which is on top. Flip this layer: Edit>Transform>Flip 
Horizontal. Rename this layer Flipped. The flipped layer is non-destructive. At 

any time we may hide it or delete it, and the underlying 
information remains intact in case we wish to modify 
it further. Save. 

Duplicate the file, and put the original away.
Flatten the duplicate (Layer>Flatten Image, or 

choose Flatten Image by clicking on the flyout triangle 
in the upper right corner of the Layers palette). 

Test the file to be sure it contains only two colors. 
Convert it to Indexed Mode (Image>Mode>Indexed, 
Palette Exact, Forced None, Transparency unchecked, 
Preview checked). The number of colors should 
be 2, which is what we want! Click OK. Save as 
Frangi2indexed.psd. Duplicate the file, and put the 
original away.

Assigning Weaves
Save the duplicate as Frangi2weaves.psd. Convert it to RGB mode 

(Image>Mode>RGB Color). Put the black and white pixels on their own 
layers. Be sure the Layers palette is open. With the Magic Wand tool, Tolerance 
0, and Anti-alias, Contiguous, and Use All Layers all unchecked, click on a 
black area of the image. With all the black pixels selected, Layer>New>Layer 
via Copy, or use the keyboard shortcut, and a new layer appears in the Layers 
palette with the default name of Layer 1. You may rename this layer by double-
clicking on its name–do this now, and call it Black Pixels.

In the Layers palette, click on the Background layer to make it active. 
With the Magic Wand, click on a white area of the image, and with all the 
white pixels selected, Layer>New Layer via Copy, and a new layer appears in 

5-4b

5-5

Note: Edit>Copy 
Merged will 
copy content on 
all layers, not 
just the active 
layer.
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the Layers palette with the default name of Layer 2. Rename it White Pixels. 
Save.

We will apply weaves to this file in the next step. You may test this layering 
operation by turning off the Background layer (click on the eye icon on the 
left). The image should appear the same. Now clicking the black layer and the 
white layer off and on, the transparent background (gray checkerboard) will 
show through. Turn all layers back on and save the file.

Here is where we add weaves to the file. Remember that we chose 1/4 and 
4/1 satin as our structures in this project? Any two weaves that work together 
would have served as well, given appropriate yarn and sett.

Go to Edit>Preset Manager, Choose Patterns from the drop down menu, 
and with the Preset Manager dialog box still open, click and hold the flyout 
triangle, and select 5-end satins from the list which appears. Click Done.

In the Layers palette highlight the layer Black Pixels and click on the “f” 
icon at the bottom to add a Layer Style. In the Layer Styles drop down menu 
choose Pattern Overlay... The Layer Styles dialog will open. Click on the 
triangle at the right of the little pattern thumbnail, choose Satin 1/4 from 
the Pattern list, Blend Mode: Normal, Opacity 100%, Scale 100%, Link with 
Layer unchecked, and Snap to Origin not clicked, Preview button checked, 
and click OK. 

In the Layers palette highlight the layer White Pixels and click on the “f”. 
In the Layer Styles drop down menu choose Pattern Overlay... Click on the 
triangle at the right of the little pattern thumbnail, choose Satin 4/1 from the 
Pattern list, settings as above, and click OK. Save.

Check for pixel leaks.When everything is OK, save the file.

Preparing the Loom-Ready File
Duplicate the file and close the original. Work on the duplicate. You will 

recall that we will be weaving this file upside down. Invert it by Layer>New 
Adjustment Layer>Invert. Flatten the file by Layer>Flatten Image, then 
index it by Image>Mode>Indexed Color. This should give you two colors, 
black and white. Save the file as Frangi2.bmp, 4-bit or 8-bit color. It is now 
loom ready. It will weave as a white drawing on a black ground, but 
when turned over it will be a black drawing on a white ground, with 
the correct left-to-right orientation. The left-to-right orientation is 
especially important in images containing text. We had an intended 
“front” and “back,” but this cloth is really two-sided, and you can use 
either side as the visible front side. A small portion of the loom-ready 
file can be seen at Figure 5-5a.

5-5a
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Third Image: Using More Filters

Preparing the Image
Again we use the starting image Frangipani2472.psd, an RGB image 

which has the pixel dimension of 1440 wide and 1200 high, resolution 72 
pixels/inch. Resize it by Image>Image Size, and in the Image Size dialog box 
check Constrain Proportions and Resample Image: Bicubic, enter resolution 
30 pixels/inch (we already know that our loom is set up this way), and for 
Pixel Dimensions, enter width 880. The height will automatically become 733 
pixels. Click OK and then File>Save As, and give it a new name (Frangi3.psd 
in this case). We will improve the contrast by Image>Adjustments>Shadow/
Highlight. We like the effect with the default settings, but you may adjust the 
sliders in the dialog box to your liking, then click OK. Save your work.

Styling the Image
Duplicate Frangi3.psd and put the original away. Proceed with the 

duplicate; save it as Frangi3styled.psd. Layer>New Adjustment Layer>Hue/
Saturation. In the New Layer dialog box, accept default settings, click OK. In 
the Hue/Saturation dialog box, Edit: Master, Preview box checked, and move 
the Saturation slider all the way to the left to remove all the color. Click OK. 
Save.

We are now going to try one of the Photoshop Filters, but we will do this 
on a separate layer so that the previous steps are preserved. With the top layer 
highlighted in the Layers Palette, Select>All, Edit>Copy Merged, Edit>Paste. 
Now with this newest layer highlighted, do Filter>Distort>Wave. In the Wave 
dialog box, experiment with the various buttons and sliders (we clicked Sine 

and Repeat Edge Pixels, set the number of Generators 
to 5, Wavelength to Min. 10 and Max 120, Amplitude 
Min. 5 and Max 35, and scale to 100%/100%). Click 
OK. Save. Rename this layer Wavy.

Now make a new layer for the Threshold operation. 
With the top layer Wavy highlighted, Layer>New 
Adjustment Layer>Threshold, and in the Threshold 
dialog box, with Preview checked, adjust the slider (we 
chose a value of 90). Click OK. Save.

We think this file needs something more–perhaps 
some brush drawing. With the top layer highlighted in 
the Layers palette, Layer>New>Layer. Accept default 
settings. With the Brush tool, color black (keyboard 
shortcut D for default color), brush size about 10 
pixels, draw on the new blank layer, concentrating in 
the white areas. Now change the brush color to white 

(keyboard shortcut X to reverse foreground and background colors) and 
draw some more on the image, concentrating on the black areas. When the 
drawing is finished, there’s one more step in the styling process. Layer>New 

5-6
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Adjustment Layer>Threshold, adjust the Threshold slider to a pleasing level 
(Preview box is checked). Click OK. Save. The completed styled file looks like 
Figure 5-6 on the preceding page.

Duplicate the file. Put the original away. Flatten the duplicate 
(Layer>Flatten Image, or choose Flatten Image by clicking on the flyout 
triangle in the upper right corner of the Layers palette). 

Test the file to be sure it contains only two colors. Convert it to Indexed 
Mode (Image>Mode>Indexed, Palette Exact, Forced None, Transparency 
unchecked, Preview checked). The number of colors should be 2, which is 
what we want! Click OK. Save as Frangi3.indexed.psd. Duplicate the file, and 
put the original away.

Assigning Weaves
Save the duplicate as Frangi3weaves.psd. Convert it to RGB mode 

(Image>Mode>RGB Color). Put the black and white pixels on their own 
layers. Be sure the Layers palette is open. With the Magic Wand tool, 
Tolerance 0, and Anti-alias, Contiguous, and Use All Layers all unchecked, 
click on a black area of the image. With all the black pixels selected, use the 
keyboard shortcut Command(Control)-J, and a new layer appears in the 
Layers palette with the default name of Layer 1. You may rename this layer by 
double-clicking on its name–do this now, and call it Black Pixels.

In the Layers palette, click on the Background layer to make it active. With 
the Magic Wand, click on a white area of the image, and with all the white 
pixels selected, Command(Control)-J, and a new layer appears in the Layers 
Palette with the default name of Layer 2. Rename it White Pixels. Save.

We will apply weaves to this file in the next step. You may test this layering 
operation by turning off the Background layer (click on the eye icon on the 
left). The image should appear the same. Now clicking the black layer and the 
white layer off and on, the transparent background (gray checkerboard) will 
show through. Turn all layers back on and save the file.

Add weaves to the file. Go to Edit>Preset Manager, Choose Patterns from 
the drop down menu, and with the Preset Manager dialog box still open, 
click and hold the flyout triangle, and select 5-end satins from the list which 
appears. Click Done.

In the Layers palette highlight the layer Black Pixels and click on the “f” 
icon at the bottom to add a Layer Style. In the Layer Styles drop down menu 
choose Pattern Overlay... The Layer Styles dialog will open. Click on the 
triangle at the right of the little pattern thumbnail, choose Satin 1/4 from 
the Pattern list, Blend Mode: Normal, Opacity 100%, Scale 100%, Link with 
Layer unchecked, and Snap to Origin not clicked, Preview button checked, 
and click OK. 

In the Layers Palette highlight the layer White Pixels and click on the “f”. 
In the Layer Styles drop down menu choose Pattern Overlay... Click on the 
triangle at the right of the little pattern thumbnail, choose Satin 4/1 from the 
Pattern list, settings as above, and click OK. Save.
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We like to check for “pixel leaks” at this point. Highlight the Background 
layer in the Layers palette, Layer>New>Layer, name it Temp, and fill it with 
a distinctive color (double-click on turquoise in the Swatches palette, then 
Edit>Fill, Use: Foreground Color, OK). If you turn off the black or white 
pixel layer by clicking the eye icon for that layer, you will see the temporary 
turquoise layer underneath, but when all layers are turned back on, no 
turquoise should be visible. This tells us that all the image pixels are filled 
with pattern. You may delete the temporary layer at this point, but it does no 
harm to leave it in place. Save. Be sure your zoom level is 100%. Sometimes 
other zoom levels will introduce colors into the screen image which aren’t 
really there, confusing you. Duplicate the file and close the original. Work on 
the duplicate. Notice that the weave image appears to be a reverse of the dark/
light values in the original black and white design. This is because the weaves 
are recorded in the Presets as black signifying warp up, a common drafting 
convention. But our loom is set up with a white warp and black weft, giving us 
the reverse effect. To visualize the woven design temporarily with the correct 
values, we may add another layer: with the top layer highlighted, Layer>New 
Adjustment Layer>Invert. Now it looks the way we expect! Turn this layer 
off or delete it. Flatten the file (Layer>Flatten Image), discarding the hidden 
layers if any. 

Preparing a Loom-Ready File
Almost done! Reduce the file to a two color weave plan by 

Image>Mode>Indexed Color, and in the dialog box select Palette: Exact, 
Forced: None, Transparency unchecked. The number of colors should be 
displayed as 2, which is what we want. If we go to Image>Mode>Color Table, 
we will see the two colors in our table, which are black and white. Click OK. 

Save as Frangi3.bmp. If you select the 4-bit option 
rather than the 8-bit option, the file will be smaller, 
but either size will work OK. The TC-1 and the AVL 
Jacquard will read files in.bmp or .tif format. 

Following are photos of fabrics woven from the 
three example files in this chapter: Frangi1, Frangi2, 
and Frangi3 (Figures 5-7, 5-8, and 5-9). The photos 
may be found in color on the accompanying CD.

5-7     Frangi1.bmp
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5-8     Frangi2.bmp

5-9     Frangi3.bmp
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File Naming Conventions
To review, these are the steps with suggested naming conventions and file 

suffixes:

•Filename.psd - the source image

•FilenameStyled.psd - same as previous, with layers, layer styles, filters, 
layer comps, etc., added

•FilenameIndexed.psd - same as previous, flattened and indexed to 
desired number of colors

•FilenameWeaves.psd - same as previous, converted to RGB, with each 
color assigned to its own layer, and weaves applied as layer styles

•Filename.bmp or Filename.tif - same as previous, flattened and indexed 
to 2 colors (b/w), loom ready.

And to wrap it all up, put the above 5 files in a folder called Filename 
Workfiles. We also like to include the original file from which the source 
image was derived, as an optional sixth file.


