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Image Into Weave

Pixels and Threads
Saving weaves as Pattern Presets is why we love Photoshop for jacquard 

and dobby design. In its simplest form, a weave diagram is a rectangular 
grid containing information about the intersections of warp and weft. The 
information in a weave diagram is binary; that is, the squares on the grid 
are either one state or another: each square represents the intersection of 
one warp and one weft, and the warp is either over the weft or under the 
weft. 

A common drafting convention holds that a black square represents 
warp over weft, and a white square represents warp under weft; this is the 
convention we will follow here.

In Photoshop, when we think about the design file in its ultimate state of 
black and white, which is the information we send to the loom, we are saying 
that each pixel represents the intersection of one warp and one weft. We may 
work with colors, layers, filters, and all sorts of enhancements along the way 
to bring our design to fruition, but the last step must always be the flattening 
and conversion of the design file to a single layer of only black and white 
pixels. 

In identifying weaves, we reduce each structure to its minimum number 
of warps and wefts that define that weave (called the repeat). A plain weave or 
tabby is defined in a 2x2 matrix, a 2/2 twill is defined in a 4x4 matrix, a 5-end 
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satin defined in a 5x5 matrix. In Photoshop we set up and save collections of 
all these weaves in sets or libraries of Pattern Presets, which are then available 
to be used in any design file. This is a great timesaver.

Setting Up Pattern Presets
It might at first seem that setting up Presets is tedious, but in actual 

practice the process is quickly learned and becomes automatic. Many of the 
steps have to be performed only the first time the routine is followed, and 
the settings will remain in place until changed. Following is a description 
of how we save a set of shaded satins as Pattern Presets. When favorite sets 
of patterns have been defined and saved (and backed up!) they may be used 
over and over in future work. Pattern Presets are small computer files that 
may be shared with other designers cross-platform; the files are the same for 
Mac and Windows. They have the suffix .pat, and are found in the directory 
Adobe Photoshop>Presets>Patterns.  A well-planned and executed set of 
Photoshop Pattern Presets is a valuable resource for any weave designer and 
should be preserved carefully. 

Copying Weave Presets Folder from CD
You may have already followed our suggestion in Chapter 3, under Preset 

Manager, to copy the Weave Presets folder found in the CD accompanying this 
book to your computer. If not, this is a good time to do it. From the desktop, 
navigate to Applications>Adobe Photoshop CS>Presets>Patterns. Now 
open up our CD, find the folder called Weave Presets and drag a copy into 
the Patterns folder. Now you have access to all the structures we discuss in 
this book and have saved as Pattern Presets. You may also save future Pattern 
Presets that you make in this folder. The Presets used in each chapter are also 
found in those chapter folders.

Preferences
First set preferences for entering weaves. Command(Control)-R to show 

rulers if they are not visible, double click on rulers, and in the Preferences 
dialog box which appears use the up/down arrows in the topmost box to 
choose Guides, Grid & Slices. In the section entitled Grid choose Color: 
Custom, choose a grid color by double-clicking on the color chip to the right, 
choose a favorite grid color (we like to use turquoise as it simulates real-
world graph paper), Style: lines, Gridline every 1 pixel, Subdivisions: 1. Click 
OK. The preferences will remain this way until reset, even after quitting the 
program. 

Note: You 
can find the 
images from 
this chapter 
in color on 
the CD in 
the Chapter 
4 folder.
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Making a Pattern Preset
Open a new file by going to File>New, set the dimensions to  

width 30 pixels, height 20 pixels (in maximum magnification this 
fits comfortably on the screen–exact size isn’t important here, as 
it is a temporary file), Color Mode RGB. The colors should be 
set to the default black and white (Keyboard shortcut D). We 
have found it easier to uncheck the Snap option (View>Snap) for 
working with single pixels at high magnification. Set the zoom 
level to the maximum, which is 1600%, by repeatedly pressing 
Command(Control)- “+” (the plus sign) until maximum zoom is 
reached. Each square is still a single pixel in the file, even though 
it is greatly enlarged on the screen. Choose the Pencil tool (if it is 
not visible in the Toolbox, click and hold on the Brush tool to see more tool 
options), and in the Options Bar choose the default settings, which are Size: 
1, Mode: Normal, Opacity: 100%. Now you are ready to start entering weaves 
on your virtual graph paper! 

Clicking on the grid, enter your weaves. For a group of shaded 5-end 
satins, your screen may look something like Figure 4-3.

Choose the Rectangular Marquee (selection) tool, and in the Options Bar 
select New Selection; Feather: 0 px; Style: Fixed Size; Width 5 px; Height 5 px. 
Click on the grid, and a 5x5 selection marquee will appear; move the marquee 
around until it exactly frames the first weave. Edit>Define Pattern, and in 
the Pattern Name pop up window, enter the name Satin 1/4, and click OK. 
You have just entered your first Pattern Preset! 

Repeat the process for the second satin, and name it Satin 2/3. Continue 
with the remaining two satins, naming them Satin 3/2 and Satin 4/1. Note 
that you could have used a Normal marquee instead of a Fixed Size marquee, 
and moved the mouse until the selection was correct. The Fixed Size marquee 
is more accurate and faster, however, especially when 
working with larger weave repeats. In this example, 
you would have changed the Style in the Option Bar 
to Fixed Size and made both the width and the height 
5 pixels each (5 px). Each time you click in your file, 
with the Selection tool still the active tool, you would 
have a 5 pixel by 5 pixel selection appear with the top 
left corner starting where you clicked. You can click 
and drag the selection to position  it where you want 
it.

Saving the Pattern Presets as Libraries
When all of your weaves have been defined, it is time to save them. 

Edit>Preset Manager brings up the Preset Manager dialog. Choose Preset 
Type: Patterns, via the drop down menu (with the double-headed arrows) at 
the top. You will see your four satins in the list (Figure 4-4). If this is the first 
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time you are opening Preset Manager, you will also have Photoshop default 
items in your list. You can highlight the unwanted items and click delete. 
They are still available for future use because Photoshop has saved them as 
defaults that you can recall.

The list display can be customized by clicking on the tiny triangle at the 
right to bring up the flyout menu, which lists the five types of pattern display 
at the very top: Text Only, Small Thumbnail, Large Thumbnail, Small List, 
and Large List. We prefer Large List, as it displays the name of the pattern and 
a large thumbnail image. If your set contains a very large number of patterns, 
you may find Small List fits better on the screen. You may customize the list 
by highlighting any items and deleting them, by highlighting an item and 
renaming it, or by dragging any item up or down in the list to change the 
order of display. When the list of patterns is to your liking, select the entire 
list (Command(Control)-A), click on Save Set, and in the Save dialog box 
name the set with a meaningful name such as Five End Satins, retaining the 
.pat suffix, and retaining the default location Patterns (or navigating to the 
Weave Presets folder that you created above), and click Save.

Your weaves are now saved in a library.  You can save the Pattern Set 
(library) anywhere. However, if you place the library file in the Presets/
Patterns folder inside the Photoshop program folder (which is the default 
location described in the previous paragraph), the library name will appear at 
the bottom of the Pattern pop-up palette menus after you restart Photoshop. 
(This is one place where Alice and Bhakti differ in their work process. Bhakti 

places all her Pattern Presets in the 
Weave Presets folder in the Pattern 
folder. She opens libraries by using the 
Load button in the Preset Manager 
dialogue box.) We also like to save a 
backup copy of our pattern libraries in 
another folder on our computer, and 
also on a CD; they represent too many 
hours of work to risk losing.

As we mention above, while in 
the Preset Manager, we delete all the patterns that ship with Photoshop by 
highlighting the entire list (with names like Bubbles, Wrinkles, etc.) and 
clicking Delete. They are always available by clicking on the flyout triangle 
and choosing Reset Patterns. And finally, via the flyout triangle, we may 
choose any Pattern library saved by the method previously described. This 
method offers the option of replacing the current patterns by clicking OK, or 
adding the patterns to the end of the current list by clicking Append (Figure 
4-5).

Using the Pattern Presets for Jacquard and Dobby
There are several ways of using the Pattern Presets; we will describe the 

method that we think works best for weave design, whether jacquard or 
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dobby. This method applies patterns as Layer Styles. The 
benefits of working with Layer Styles are: 

Make Separate Layers for Each Color
Our sample file is an RGB file with 6 colors. We made 

separate layers for each color by using the Magic Wand 
and clicking on a color in the Background Layer, then 
using the keyboard shortcut Command(Control)-J. 
The image looks like Figure 4-6. Chapter 5 has more 
information on separating a file into layers. The associated Layers Palette 
is shown in Figure 4-7. It has an additional layer, the Temp (Turquoise) 
layer, which is explained below.

Layer styles may be assigned through the Menu (Layer>Layer 
Style>Pattern Overlay, which brings up the Layer Style dialog box) 
or directly through the Layers Palette, which is quicker. With the top 
layer (the “Lt gray ground” layer in our example) in the Layers Palette 
active (to make a layer active, click on it and it will turn blue in the list), 
find the tiny f symbol (called the “add a layer style” button—it is circled 
in Figure 4-7) at the bottom of the palette, click and hold it to reveal 
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•The styles are non-destructive and may be 
changed even after the file is saved, closed, and 
reopened;

•The layers and their associated patterns may be 
reordered (the stacking order changed);

•The files may be resized and the patterns (weaves) 
remain intact and weavable.
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the list of available styles, choose Pattern Overlay, and the Layer 
Style dialog box appears. It looks like Figure 4-8 on the previous 
page.

The first pattern in our current set appears in the Pattern 
Thumbnail; clicking on the tiny flyout triangle in the blue area 
to the right of the thumbnail (also called the “pattern picker,” it 
is circled in yellow in Figure 4-8), reveals the entire set. In this 
example the set is one we previously saved as Birdseye 8x8. The 
Pattern Picker looks like Figure 4-9 when we select the Birdseye 
patterns.

We can either accept the currently displayed patterns or 
choose another one via the flyout triangle in the upper corner 
of the Pattern Picker window, circled in yellow in Figure 4-9. 
If you do that, you will get the same Menu window that can be 

found by going to Edit>Preset Manager>Patterns and clicking on the 
flyout triangle in that window. Photoshop often gives you several ways 
to get to the same place. Figure 4-10 shows you an example of what the 
choices are when you click on the flyout triangle of the Pattern Picker. 
Note that one of the choices (circled in yellow) is Preset Manager. If 
you have saved folders of Pattern Presets in a master Weave Presets 
folder (which is nested in the Patterns folder, as Bhakti likes to do), you 
can click on the Preset Manager choice and navigate to those folders 
and their Pattern Presets. 

The items listed in the bottom section of the window are the Preset 
libraries that reside in the Pattern folder. It will list libraries located 
in a folder under Pattern also, but not folders within those folders. 
In other words, if you have stored a library in this nesting order: 
Preset Manager>Patterns>Weave Presets>Lampas, and the Pattern 
Presets are located in Lampas, you will see them on this list. But if 
you go one folder deeper, like this: Preset Manager>Patterns>Weave 
Presets>Lampas>1to1Lampas and the Presets are in the 1to1Lampas 
folder, you need to access them from  Load>Preset Manager. If you saw 
Bhakti’s real life file cabinets and folder systems you would understand 
this excessive nesting system.

Let’s get back to choosing a Pattern Preset. Be sure the Link with 
Layer button is unchecked, and the Snap to Origin button is not clicked 
(unfortunately there is no indication whether Snap to Origin button 
has been clicked or unclicked—just remember, DO NOT click this 
button), the Blend Mode is Normal, the Opacity is 100%, the Scale is 
100%, and the Preview button is checked. Click OK.

Snap to Origin and Link With Layer: Don’t Use
We should say something further about Snap to Origin and Link with 

Layer. We want the Pattern Presets to fill the image starting from the top 
left corner and moving down. If you select Link with Layer, and you move 
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the position of that layer within the file, the Pattern 
Overlay will move too, starting in a new place. This will 
most likely cause the weave structure and the weft color 
sequence to work out of sync with each other. It is not 
critical for single constructions (one warp and one weft), 
but critical for compound cloth. Snap to Origin means 
the Pattern Overlay will flood into the image from the 
first pixel present in that layer, which often is not the top 
left corner of the image. Again, the synchronization of 
the weave structure and the weft color systems will most 
likely be thrown off, and the file will not weave as you 
expect it to. Therefore, we always tell you in this book: 
Do NOT click on Snap to Origin and make sure Link 
with Layers is unchecked.

The image now looks like Figure 4-11, with the first 
pattern applied to the first layer. The Layers palette is 
shown in Figure 4-12.

Notice that in the Layers palette there is a tiny f in the layer title 
for the “Lt gray ground”, indicating that a Layer Style (weave) has been 
applied. Continue in this manner through all the layers, applying a 
weave to each layer in turn, until the entire design is filled with black 
and white pixels, signifying weaves.

Temporary Layer to Check the Weaves
We added another layer, The Temp (Turquoise) layer, above the 

Background layer and below the layers with color separation. It is a 
checking device–if any areas of the design are not filled with weaves, 

the turquoise will 
“leak” through and 
warn us. We may 
also check our work 
by turning each layer 
off and on by clicking 
on the eye icon to the 
left of each layer name 
in the palette. As a 
layer is turned off, or 
rendered invisible, the 
turquoise temporary layer 
will show through. Turn all 
layers back on and save the 
work as a .psd file so layers 
are intact.

4-11
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We encourage you to apply weaves to all layers and save this file, since we 
will refer to it later in the chapter. If you haven’t followed our suggestions to 
copy the Weave Presets folder from the CD to your computer, you can also 
find the Birdseye Presets in the CD under the folder for Chapter 4.

We have applied weaves 1 through 6 in the Birdseye set to the six layers of 
the image. It now looks like Figure 4-13 on the previous page.

Duplicate this file and flatten the duplicate, then index it (Image> 
Mode>Indexed Color), and in the Indexed Color dialog box, Choose Palette: 
Exact, Forced: None, and Transparency unchecked. The number of colors 
displayed should be 2. If it is not, there is an error in one of the preceding 
steps. Correct errors if necessary. Click OK. Save the file as a .bmp or a .tif. 
It is now readable by a TC-1, an AVL Jacquard, and some industrial jacquard 
looms. If you have a loom, be sure it reads black as risers and white as sinkers; 
if it doesn’t, invert the file before sending it to the loom.

Resizing the File for Correct Aspect Ratio
Let us first examine the relationship between warp, weft, and pixel. The 

intersection of one warp and one weft, if they are the same size and if the 
epi is the same as the ppi, is square. A pixel on your computer monitor is 
also square. If the warp/weft relationship in the woven cloth is not square, 
the optimal size of the pixel will have to be elongated or squashed to make 
the representation of the fabric on the monitor accurately reflect the relative 
dimensions of the woven cloth (Figure 4-14).

If you design a weaving file with square pixels and the true relationship 
of warp to weft is not square, when the file is woven it will appear either 
stretched or squashed. This, in a nutshell, is the dilemma of the woven pixel—
yarns have different dimensions that affect the visual output of the image in 
the cloth. The relationship between the size of the warp and weft yarns, that 
is, the shape of their intersection or the pixel in digital design, is known as 
Pixel Aspect Ratio.

In Photoshop, the Pixel Aspect Ratio is found by dividing ppi by epi. 
This might be different in other software programs, so don’t get confused. 
Remember:

Pixel Aspect Ratio = ppi/epi

4-14
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This is a construct that Alice and Bhakti have discussed at some length. If 
a designer is working in a mill with standard, predetermined constructions, 
then the ends per inch and the picks per inch, and perhaps even the exact 
group of weaves to be used in the cloth, are known. In this case, the designer 
already knows the true Pixel Aspect Ratio of the cloth, and can design using 
this factor. Textile designers can create hundreds of designs where the only 
element that changes is the visual image (and perhaps the yarn colors), and be 
confident that the designs will all weave correctly at the mill.

However, if every fabric that you weave is a new endeavor, then you are 
only guessing at the right Pixel Aspect Ratio for your design work. In this 
case, does it make sense to design on custom pixels? We really don’t have an 
answer. Bhakti is indoctrinated in the concept of custom pixels, and would 
rather begin with an educated guess of the ppi and epi and the resulting 
aspect ratio. If she is way off, she will then resize the design. She is willing to 
tolerate slight elongation or squashing of an image in her work, but is quick to 
stress that she will always make changes if the results bother her. Alice, on the 
other hand, has had no trouble working with square pixels, and almost always 
does a woven test to find the correct Pixel Aspect Ratio when weaving a new 
project. Then she modifies her design, still using square pixels, knowing that 
the image will look squashed or elongated on the computer screen but will 
square up perfectly in the cloth.

You will have to come to your own conclusions as to whether or not you 
want to design with square or custom pixels. We are going to take you through 
both methods: first explaining the process of designing using square pixels, 
then the process using custom pixels. We think you should try both methods 
and see which you prefer. Actually, we think you will find that you use both 
methods, choosing the most apt for each of your projects.

Designing with Square Pixels 
When the True PPI is Unknown

For every new file, weave a few inches to see if the design weaves square. 
If it doesn’t, you must change the aspect ratio and resize the design file. A 
squashed image means you are weaving more picks per inch (ppi) than ends 
per inch (epi); an elongated image means you are weaving fewer ppi than epi. 
Measuring from the woven sample, divide the number of picks per inch by 
the number of ends per inch to find the Pixel Aspect Ratio of this particular 
warp and weft combination. Remember, Photoshop’s Custom Pixel Aspect 
Ratio function requires that you divide ppi by epi; this may be different in 
other textile programs. 

As an example, if the loom is set up with 30 ends per inch and the test 
fabric weaves at 24 picks per inch, the aspect ratio is 24/30, or .8 (eight 
tenths). This means that the image in the fabric will be elongated in the warp 
direction. You must multiply the pixel height of the design by the aspect ratio 
to resize the file. Go to Image>Image Size, uncheck Constrain Proportions. 
Make sure Resample Image reads Nearest Neighbor. Change the height of 

Note:
You must 
multiply 
the pixel 
height of 
the design 
by the 
aspect 
ratio to 
resize the 
file.
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the image to the new number of picks (the number you just got by multiplying 
the original height in pixels by the aspect ratio of the file). It is a good idea to 
have the height be a number that is evenly divisible by the picks in a repeat 
of your structures if they are all the same height, or a common denominator 
for all of them if they are different heights. This will ensure that weft color 
rotations match the structure(s) repeat, and if you are doing multiple repeats 
of your image, there will be no division between the beginning and end of 
each repeat. Click OK.

The image will now appear either vertically squashed or elongated on the 
monitor, but it will weave as originally designed. There is a simple solution 
to the visual problem on your monitor: change the Pixel Aspect Ratio to the 
true aspect ratio (.8 in our example), and the image will now look correct on 
your monitor. You haven’t changed the actual number of pixels in the resized 
file, only the shape of the pixels, which are now squashed or elongated (if you 
used .8) vertically.

This is so important that we will go through an example of resizing an 
image using this method. We hope you saved the layered image file with 
weaves imposed as Layer Styles, 4-13.psd on the CD (Figure 4-13).

Resizing Figure 4-13 for the Correct PPI
Our original design was sized at 400 by 400 pixels. We duplicated file 4-

13.psd, flattened the duplicate and saved it as a .bmp file. We wove an inch or 
two of the design, then with the tension released on the loom, counted the ppi 
and epi in the relaxed fabric. Dividing the ppi by epi, we derived the true Pixel 
Aspect Ratio of .8. We then multiplied the height of the original design (400) by 
.8 to get 320 pixels as the new height of the file. Working in another duplicate 
of the file (duplicates allow revision of the original if something goes wrong), 

go to Image>Image Size. It brings up the Image Size 
dialog box. Uncheck the Constrain Proportions box. 
In the Height box in the Pixel Dimensions section, 
enter 320. Important: Be sure that Nearest Neighbor 
is selected as the resampling method by clicking on 
the drop down menu next to Resample Image. Click 
OK (Figure 4-15). 

Now look at the resized file–it has changed its 
height, but the weaves are still correctly assigned 
with no extra work! Duplicate the file, and flatten 
the duplicate. Export this flattened file to the loom. 
It will weave at the correct aspect ratio. If you wish 
to view the image on the computer screen with its 
correct proportions, go to Image>Pixel Aspect 

Ratio>Custom, give the new ratio a descriptive name (perhaps the name of 
the file you are weaving), enter the aspect ratio in the Factor box (.8 in our 
example), and click OK.

4-15
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If you have a loom near by, this method is so simple and 
easy to use. You also can return to your layered file, with 
weaves as Layer Styles, and replace the Pattern Presets with 
a new set of weaves. The combination of the new structures 
might affect the ppi of the cloth, causing you to resize the 
file again, but as you can see, this is easy to do without any 
adjusting of the image. Why not weave a favorite image 
several times, each time inserting a new set of structures 
(Pattern Presets) into the file? If you change the weft colors, 
as well as the weaves, you might have a series that reminds 
you of Monet’s haystack paintings, basically the same image 
modified by the changes of light from dusk to dawn. Figure 
4-16 has six steps of an 8-end satin, shaded in the weft 
direction (these Pattern Presets can be found in the Chapter 
4 folder on the CD as well as in the Weave Presets folder) 
added as Layer Styles to a duplicate of Figure 4-13.

Designing for Cloth Using  
Custom Pixel Aspect Ratio

Photoshop CS introduced the ability for users to create custom size pixels 
shaped as vertical or horizontal rectangles rather than just squares. This 
immediately made it a more attractive program for textile designers who 
have traditionally designed on point paper sized to the correct proportion of 
warp and weft. If you have spent many hours cleaning up a design, making 
the contours of the shapes just right, you might not be happy with the 
modification of your image that occurs when you ask Photoshop to resize 
your work. Working on a grid that reflects the true ratio of weft to warp will 
mean that when you draw a circle, it will weave as a circle.

The following is a series of images illustrating how a circle, drawn on 
square pixels, will look in the cloth with varying weft to warp ratios (different 
Pixel Aspect Ratios).

4-16
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First we have the original image, file size 50 x 50 (i.e., 50 ends and 50 
picks), drawn on square pixels (Pixel Aspect Ratio equals 1). This circle is 
approximately 2.5 inches in diameter, if woven with equal ppi and epi of 20 
ppi and 20 epi (4-17).

Here is the same file, with the Pixel Aspect Ratio changed to .5 (Figure 
4-18). Note that the pixels are now elongated in the warp direction. This is 
how the circle will look in cloth where the warp is sett at 40 epi and the weft 
weaves at 20 ppi. The Pixel Aspect Ratio of .5, was derived by dividing 20 by 
40 (ppi/epi). The number of pixels in the image has not changed—only the 
shape of the pixel has been modified. In the cloth, the original circle with a 
diameter of 2.5 inches would now be 1.25 inches wide and 2.5 inches high. A 
cloth with more ends than picks in an inch will have an aspect ratio less 
than 1, and the grid will have vertical rectangles as the pixel shape.

Here is the same circle, viewed with an aspect ratio of 2 (Figure 4-19). 
Now the pixels are elongated in the weft direction. This is how the circle will 
weave in cloth when the warp is sett at 20 epi and the weft is thrown at 40 ppi. 
The Pixel Aspect Ratio of 2 is derived by dividing 40 by 20 (ppi/epi). Note, 
that the number of pixels in the image has not changed—only the shape of the 
pixel has been modified. If woven, this circle would now be 2.5 inches wide 
by 1.25 inches high. A cloth with fewer ends than picks in an inch will have 
an aspect ratio greater than 1, and the grid will have horizontal rectangles as 
the pixel shape.

Here is another way to visualize what is happening in your designs with 
custom pixels. We are repeating the rules we just gave you with explanatory 
images:

•A cloth with more ends than picks in an inch will have an aspect ratio 
less than 1, and the grid will have vertical rectangles as the pixel shape. The 
cloth illustrated in Figure 4-20 has a Pixel Aspect Ratio of .5.

•A cloth with more picks 
than ends in an inch will have 
an aspect ratio greater than 1, 
and the grid will have horizontal 
rectangles as the pixel shape. The 
cloth illustrated in Figure 4-21 
has a Pixel Aspect Ratio of 2.

If you start out drawing the circle in a file using the correct aspect ratio, 
then the size of the circle will be modified by the aspect ratio. It will not cover 
the same number of ends and picks as the circle drawn with square pixels, 
but it will look like a circle both in the design and in the cloth. If we knew 
that we wanted a circle 2.5 inches wide, on a sett of 40 epi and 20 ppi, aspect 
ratio of .5, then we would need a file size of 100 wide x 50 high. When we 
opened the new file window, it allowed us to choose the custom Pixel Aspect 
Ratio, because we had saved the factor when we used it. If you click the flyout 
triangle next to the Pixel Aspect Ratio item in the New window (circled in 
red in Figure 4-22), a pop up window opens letting you choose one of your 

4-20
4-21



59Image Into Weave

saved custom Pixel Aspect Ratios. If you need a ratio that you haven’t saved, 
just choose square (the default pixel size), click OK to open the new file, then 
go to Image>Pixel Aspect Ratio and create a new factor (and save it). Your 
file will be modified to show the new ratio.

The circle in Figure 4-23 has been drawn with 40 epi and 20 ppi (40 pixels 
wide x 20 pixels high), and has an aspect ratio of .5. The circle in Figure 4-24 
has been drawn with 20 epi and 40 ppi (20 pixels wide x 40 pixels high) and 
has an aspect ratio of 2. They will both appear the same on your computer 
monitor, even though their actual Pixel Aspect Ratios are different, reflecting 
the actual warp to weft ratio in the cloth.

If you are drawing your design directly in Photoshop, then creating your 
new file in the correct Pixel Aspect Ratio means that your drawing is being 
executed as it will appear in the woven cloth.

4-23 4-24
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Starting with an Image that has Square Pixels
If you are working with scanned images or images from a digital camera, 

which are captured with square pixels, you want to scale these images first, 
to reflect the Pixel Aspect Ratio, before beginning to clean up or modify the 
design. Let’s go through an example of the process using a digital image as 
the starting point.

The first step is to resize the file to reflect the epi and ppi of the final image. 
Let’s assume that we are going to weave this image on a warp at 30 epi and 24 
ppi (which will give us a Pixel Aspect Ratio of .8). First we want to find out 
the ratio of the height to width of the original image, because we will want 
to keep that ratio. Go to Image>Image Size and write down the width and 
height of the design. In our case, at a resolution of 72 (we are starting with a 

low resolution digital image) we 
find the width = 11.292 inches 
and the height is 19.333 inches 
(Figure 4-25).

We need to modify the image 
in two steps, since epi and ppi 
are not equal. Which number is 
higher, the ppi or the epi? Modify 
the image first for the higher of 
the two, then modify the other. 
This will help you preserve the 
detail of the image. Since our 
epi is higher than the ppi, we 
will correct the width first. Go 
to Image>Image Size. Make 
sure that neither Constrain 
Proportions nor Resample Image 
is checked. Change the resolution 
to 30 and note that it has changed 
both the height and width of the 
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image, keeping their proportions. Now click on Resample Image, leaving it 
at Bicubic, and change the width to the number of ends on the loom (880 in 
our case). Now the width of our cloth is 29.33 inches, which is correct for the 
loom, and the height is 46.4 inches. Click OK (Figure 4-26). 

The sequence of steps is important here—you need to modify the resolution 
first, then change the width or height. (If you are mathematically inclined 
and want to be sure the new size is in the same proportion as the original 
image, compare 11.292/19.333 to 27.1/46.4 either by  multiplying 11.292 by 
46.4 and 19.333 by 27.1 and comparing the numbers—we get 523.9 for both of 
them—or dividing the two ratios—we get .584 for each of them—and seeing 
if they are the same. The calculator on the computer is very helpful here.) 

Now we need to modify the height to reflect the true ppi of 24. Multiply the 
new height, 46.4 by 24 to get the number of picks in the design. We get 1113.6. 
Round the number up or down to reflect a number that will divide evenly 
into the structures you will use. Let’s use the same 8-end satins as above. 1112 
picks will weave complete rotations of these structures. Go to Image>Image 
Size and uncheck both Constrain Proportions and Resample Image Size. 
Change the resolution to 24. Now click on Resample Image (you can leave it 
as Bicubic). Change the height to 1112. Do you see that the height of the image 
now reads 46.333? This is what we want. Click OK (Figure 4-27).

Oh no, your image now looks squashed, doesn’t it? We have to change 
the Pixel Aspect Ratio to reflect the true ratio. Go to Image>Pixel Aspect 
Ratio>Custom Pixel Aspect Ratio. Change the factor to .8, and give the ratio 
a name. It will remain in your list for future use. Click OK. Now your image 
looks the way you expected it to look and it is resized correctly. If you want 
to see your pixel shape, turn on grid and zoom up to a resolution where you 
are seeing single pixels. Your pixel shape should be a rectangle elongated in 
the vertical direction (the wefts are thicker than the ends). The Pixel Aspect 
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Ratio has not changed the number of pixels in the 
image; there are still 880 pixels in the width and 
1112 pixels in the height—but their shape has been 
modified (Figure 4-28).

Now you can work with the correct custom 
Pixel Aspect Ratio and reduce your design, draw 
in it, use filters, curves, and any other Photoshop 
feature you need to make the design the way you 
want it for weaving.

By the way, you might notice that sometimes 
Photoshop will show you a dialogue box that says 
“Pixel aspect ratio is for preview purposes only. Turn 
it off for maximum image quality.” You can check 
the box, “Don’t show again” and you won’t have to 
see this annoying dialogue again. Or you can just 
click OK. What it is telling you is that the custom 
aspect ratio remains with the design, which is what 
you probably want.

Designing for the Face of the Cloth
There is another method of working, whether you are using square or 

custom pixels, which is important to discuss here—designing for the face of 
the cloth. If you are working with a simple cloth structure, one warp system 
and one weft system, as in a shaded satin construction, then your cloth builds 
pick by pick, end by end, side by side. That is, each warp end lies in the same 
plane as the adjacent ends, and each pick lies in this same plane. When you 
flood the color of the design with weave structure, there is a 1:1 ratio of your 
design to your final structural image—a design 100 pixels wide by 50 pixels 
high will end up with structures that fill 100 ends and 50 picks. 

Textile designers working on point paper, and now with software, usually 
design for the face of the cloth when the structure is a compound cloth. This 
means that if the final fabric has a series of six warp systems and three weft 
systems (a common construction for warp tapestry), the initial design will be 
1/6th the width of the final design, and 1/3rd the height of the final design. In 
this case, each design pixel of the face design will equal 6 warps and 3 picks 
when the design is expanded. The expanded file represents every end and 
pick in the final cloth, and weave structures are not put into the file until it is 
expanded.

Color Sequences of Warp and Weft  
Versus Warp and Weft Systems

It is important that you understand that a warp system is different from 
the color sequence of the warp. You can have a simple construction of one 
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warp system and one weft system, but have the warp color change every inch 
to make warp stripes, and have the color of the weft system change every half 
inch to make thinner, horizontal stripes. In this case, the color of the warp 
and weft, though it will affect the look of the final cloth, has nothing to do 
with the structure. If you are using a 1/3 weft twill in this fabric, the structure 
is the same throughout the cloth, it just appears different because of the end 
and pick color sequences.

If you are designing a fabric that will be woven as double plain weave, 
you know that you have two systems of warp and two systems of weft. One of 
those systems can be monochromatic, say white warp and white weft weaving 
a plain weave. The other system might be a warp ombré that shades from 
light yellow to pink, then to orange, and ends in red, working with a solid 
black weft, but also weaving as plain weave. The color of the second warp 
system will give complexity to the look of the final cloth, but the structure 
throughout, will still be double plain weave.

Designing for the Face in Double Plain Weave
In the example of double 

plain weave, if you are 
designing for the face of the 
cloth, you would halve the total 
number of warp ends and halve 
the total number of weft ends. 
To be more specific, if the final 
cloth will be woven on a loom 
with 1200 ends and 1200 picks 
(assuming the Pixel Aspect 
Ratio is 1, i.e., the thickness 
of the warps is the same as the 
thickness of the wefts), you 
would halve that number (600 
pixels wide by 600 pixels high) 
to design for the face of the 
cloth. A face pixel is eventually going to represent 4 pixels in the final design 
(the intersection of 2 ends and 2 picks)  In Figure 4-29 the small flower is the 
face design and the large flower is the expanded image.

If working with custom Pixel Aspect Ratio, the ratio for the face design 
might be different than the ratio for the final design. To discover the Pixel 
Aspect Ratio for the face divide the face ppi by the face epi.

If you are working on large files with compound structures, it will be easier 
and faster to design for the face of the cloth than for the full number of ends 
and picks. Even with the speed of today’s computers, you will find that some 
work, like the designing for an industrial loom set up for warp tapestry (see 
Appendix D for detailed instructions), takes considerable time to compute. 
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Also, designing for the face cloth can ensure that a pixel becomes the size of a 
structural repeat, or a portion of it, not just a random riser or sinker.

Expansion of the Face Design
After you complete your design, you need to expand it. In Photoshop, you 

would go to Image>Image Size, and in the dialogue box that opens you need 
to change the number of warps and wefts. In our example, the ratio of warp to 
weft is 1:1, and we want to keep that, so we check Constrain Proportions. This 
ensures that when we change the number in either the width or the height, 
the other will change too. Be sure to have Resample Image checked and set 
to Nearest Neighbor. You want Photoshop to copy pixels, not add new colors. 
If you didn’t want to do the math, you could make the width and height into 
percent, rather than pixels, and put in 200 percent. That is what we did to get 
the expanded image on the right in Figure 4-29.

Uneven Compound Cloth Expansion
If you are working on a compound structure, the number of warp systems 

is not always the same as the number of weft systems. A common compound 
construction in the textile industry is warp tapestry. If the loom is set up 
with six warp systems (that is, a rotation of six colors, but each color is its 

own layer or system) and three weft systems (usually two heavy 
weft yarns, and one thin, binder weft), then each pixel of the face 
design will need to be expanded to represent 6 ends and 3 picks. 
One pixel in the face design will end up being 18 pixels in the final 
cloth. Figure 4-30 shows how one pixel becomes 18, and also, on 
the right, it shows the warp systems and weft systems that the 
pixels will represent.

Let’s go through an example of this set-up. Assume the six warp systems 
have a true sett of 84 epi, and the three weft systems will weave at 60 ppi. The 
true Pixel Aspect Ratio (ppi/epi) equals 0.714. However, the face Pixel Aspect 
Ratio is different. The sett of the face warp is 84/6, or 14; and the sett of the 
face picks is 60/3, or 20. Dividing the face picks by the face ends (20/14) we 
get 1.429 for the face Pixel Aspect Ratio.

If the full width of the loom is 60 inches, your face design is going to have 
14 x 60 (or 840) ends or horizontal pixels. If the height of your design is going 
to be 20 inches, then the face height is 20 x 20 (400) picks. Therefore, you 
would design in a file that was 840 pixels wide by 400 pixels high, with a Pixel 
Aspect Ratio of 1.429. When the design is complete, and reduced to the final 
number of colors, it must be expanded before adding weaves as Layer Styles. 
Go to Image>Image Size, make sure Constrain Proportions is not checked, 
and have Resample Image set at Nearest Neighbor. Change pixels to percent, 
next to either height or width (they will both change to percent). Make the 
width read 600 percent, and the height read 300 percent. Click OK. Now 
your image has expanded to the true number of ends on the loom  and picks 
to be woven. The image will not look right though, because it is still being 
viewed with the Pixel Aspect Ratio of the face. Go to Image>Pixel Aspect 
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Ratio>Custom Pixel Aspect Ratio and put in the true ratio of 0.714. The 
image will now look correct, even though the actual number of pixels has not 
been changed. You can now add the structures as Layers Styles, assuming you 
have saved them as Pattern Presets. Duplicate your image, flatten it, and save 
as a .bmp or .tif file. Appendix D gives you specific information on designing 
warp tapestry and sending it to a mill to be woven.

Designing for the Face and 
Expansion for a Simple Structure

Although we normally would design for the full width of the cloth on a 
simple structure of one warp and one weft system, there are cases where we 
might decide to design on a fraction of the cloth. Satin damask is one instance 
where this might be useful. Most satin damask fabrics use two structures, a 
warp satin and a sateen of the same counter. We can design these structures 
so they meet each other at boundaries, with a warp float adjacent to a weft 
float. If the design is very geometric, this kind of intersection adds to the 
sophistication and crispness of the image. For a very organic, free-flowing 
design, designed full-width, then this type of juncture is not essential, since 
the intersection of the structures can happen anywhere.

Still, designing for the face of the cloth makes sense 
for damask. Here is an example, using the five-end satin 
versus five-end sateen as the two structures. Design and 
save these weaves so that when they line up next to each 
other, or above or below, the floats are locked. This means 
we can’t start or end the weave with a sinker at a corner 
for satin, or a floater at a corner for a sateen. For the five-
end satin, we can begin with either end 2 or end 4 down 
on the first pick and build from there. Usually the sateen 
weave is just the opposite from the satin. Figure 4-31 
shows the two structures and how they lock with each 
other when full repeats of the structures are used.

Let’s assume that the design has 60 epi. This means there are 12 repeats of 
the five-end structures in an inch. If we always want the structures to weave 
as a complete unit, we can design for the face of the cloth, using 12 as the face 
epi, and then expand by 5 after all the design work is finished. For the weft, 
assume there are 60 ppi in the cloth. Since each structure needs five picks per 
unit, there will be 12 repeats of the picks per inch, so the face ppi is 12. In this 
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case, both the face and the real cloth end up with 1:1 relationships between 
the number of picks and the number of ends. Square pixels will work for this 
design. 

Let’s work with Figure 4-25 for the damask design. If the warp is 40 inches 
wide on the loom, the full design is 2400 pixels wide, but the face is one-
fifth of that, 480 ends. We go to Image>Image Size and have both Constrain 
Proportions and Resample Image checked. In this example, we left Bicubic 
as the default. We changed the width to 480, which resulted in the height 
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being changed to 822. This is not a number divisible by 5, so we 
unchecked Constrain Proportions and changed height to 820. 
Click OK. 

We only need two colors in our design to represent the 
two structures of the damask. Image>Adjustments>Threshold 
quickly converts the image to black and white, as shown in 
Figure 4-32.

Now we need to expand the image by five in both width 
and height. Go to Image>Image Size, have both Constrain 
Proportions and Resample Image checked, and be sure Nearest 
Neighbor is selected, change pixels to percent next to height or 
width, and put in 500 percent. Click OK. Now make layers out of 
each color and put in the weaves as Layer Styles. We don’t have 
to worry about Pixel Aspect Ratio in this case because warp and 
weft are the same sizes (epi = ppi). We used the five-end satin 
for the ground and the five-end sateen for the figure. This makes 
the image look reversed with structure, since the white ground 
is now filled with a structure that is warp-faced (therefore you 
see many black pixels). A section of the image with the structure 
is shown in Figure 4-33.

Do you see the area in the top right of Figure 4-33 where the 
elements are small? When we zoom into that area, it is easy to 
see that they represent full repeats of the structures. Figure 4-34 

shows that area blown up.
The Pattern Presets for this damask are 

found in the folder for Chapter 4, as well as 
in the master Weave Presets folder.

Testing Weaves - The Weave Blanket
Before assigning weaves to a jacquard or dobby design, we need to know 

the woven appearance of the weave structure. A woven diagram on the 
computer or on point paper will give an approximation, but as any weaver 
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knows, the woven cloth is often very different from its graphic representation. 
In addition to the appearance of individual weaves, woven samples will tell us 
how weaves appear in relation to other weaves. Only then will we be able to 
use a given collection of weaves as a palette in a design. 

By arranging all the weaves in a project into a single blanket or sampler 
file, then weaving this blanket with the exact yarns and sett to be used in the 
final project, we can generate a design reference that will tell us, when viewed 
at the appropriate distance, the hue and tonal value of each of our weaves. 
Then we are able to assign the weaves intelligently, knowing in advance the 
appearance they will produce. 

A well-planned blanket may tell us that even though we have devised 
scores of weaves for a given set-up, many of them are so similar as to be 
indistinguishable from one another, and there are actually only eight distinct 
weaves in the set. This is useful information, and leads us to a design decision: 
when reducing the number of colors in our file by indexing, we will choose 
eight as the final number of colors, assign each color to its own layer, and 
assign each of the chosen weaves as a Layer Style.

Sometimes the dobby or shaft loom can be used for quick and dirty 
samples when we don’t care to go to the trouble of planning and weaving an 
entire blanket. For instance, if we plan to use a shaded 7-end satin (pattern 
repeat sized 7x7), we can set up a sample warp of straight draw on shafts 
one through seven of an 8-shaft loom, in the same yarns and sett to be used 
in the final project, and weave all six iterations of the satin. The ppi might 
vary in the final cloth due to the width of the sample versus the width of the 
final cloth (and the final cloth has combinations of structures across the web 
of the cloth, another source of variation of the ppi). Still, you’ll get a good 
approximate ppi to design with. Your ppi and look of the cloth will be affected 
by the type and size of the yarn; you learn so much by sampling!

 

Combining Weaves
With the absolute freedom of the jacquard loom, weaves may be combined 

which in some cases produce problem areas at the design edges where one 
weave meets another. There are two ways to approach this issue. The first is to 
choose weaves which are preplanned not to cause overly long floats where they 
combine. This is the system that is employed in network drafting on the dobby 
loom (more about this in Chapter 15). The second approach is to correct floats 
after the weaves are assigned and the layers flattened. In some cases, the float 
correction can be done automatically via the loom driver software (as is the 
case with both the TC-1 and AVL Jacquard looms). Alternatively, “boundary” 
areas may be built into the design. A two- or three-pixel boundary of a unique 
color may be drawn around design areas in Photoshop, these pixels assigned 
to their own layer, and a plain weave or other small repeat weave assigned to 
this layer as a Layer Style. The plain weave barriers will effectively limit the 
potential extra-long floats at the edges of designs. 
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Unfortunately there is no way we know of to check floats and correct for 
overly long floats in Photoshop, but by judicious planning of weaves or use of 
boundary weaves the problem may be headed off before it arises.

Shaded twills and satins are good examples of weaves which combine 
correctly within each class, with no problem floats. The shaded weaves are 
formed simply by starting with the least warp-faced weave in the set. For 
example, to form a group of 8-end shaded satins, start with a 1/7 satin (Figure 
4-35).

For the second weave in the group, add a single pixel to the right of each 
pixel in the first weave, wrapping around to the left when you reach the right 
edge (Figure 4-36) and this is the 2/6 satin. Notice that each pixel of the 1/7 
satin is included in the array of the 2/6. This is the principle of inclusivity, 
which is what makes the satins in each group work together perfectly. In each 
group of inclusive weaves, each weave is included in its successor, and every 
weave includes the weaves prior to it in the group order. Chapter 7 deals with 
shaded weaves in greater detail.

Figure 4-37 shows the final group of seven 8-end satins.
Pixels in this example were added to the right of existing pixels (this is 

shading in the weft direction) but they could have been added to the left, 
or above or below, as long as a consistent order is maintained in each group 
of weaves. Some shading orders emphasize warp, others weft. Sample to 
determine which effect is better for your particular project.

Other groups of weaves may be selected on the basis of 
inclusivity. Following are sets of inclusive 4-end straight twills 
(Figure 4-38) and inclusive 4-end broken twills (Figure 4-39). 

Note: even though all sorts of twills and satins may be 
combined in one jacquard composition, they will not work as 
inclusive weaves unless only weaves of a single set are combined 
(i.e., you may combine the 1/3 straight twills with others in the 
same inclusive group, but not with 1/3 broken twills). 

In actual practice, the inclusivity principal may safely be 
ignored as long as the designer reviews the file for overly long 
floats, either by a visual check of the design or automatically in the 
loom software. If only inclusive weaves are used in any given file, 
the float check may be omitted. 
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4-40

4-41

The size of float that is acceptable depends on the size of yarn and the end 
use of the cloth. Industry has very stringent standards that meet the strict 
guidelines imposed by government–but an artist doing wall hangings or 
making upholstery for her own use can accept longer floats. Still, you might 
ask, how long is acceptable? We know of some artists who have woven 4 inch 
headers, leaving their unused warp loose for 4 feet, and woven another 4 inch 
strip, and hung the work horizontally so the warps sag in an arch–is that long 
enough for you? 

The example in Figure 4-40 uses inclusive twills and there are no floats 
longer than 3 in either direction.

In Figure 4-41, non-inclusive twills were used, and small areas of 4-end 
warp floats can be observed, circled in red.



70 Chapter 4

4-42

In Figure 4-42, we show an example of the use of barriers of plain weave 
between areas of various weaves.


